What’s Vulnerable › Vulnerabilities
CVE-2023-25859: Adobe Illustrator Improper Input Validation Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-22 · updated 2026-06-17
- Weakness: CWE-20
Description
Illustrator version 26.5.2 (and earlier) and 27.2.0 (and earlier) are affected by an Improper Input Validation vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Illustrator: through 26.5.2; from 27.0.0 before 27.3.1 — fixed in 27.3.1
How to fix
Upgrade to a fixed version: Adobe Illustrator 27.3.1. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/illustrator/apsb23-19.html
- https://helpx.adobe.com/security/products/illustrator/apsb23-19.html
Get alerted when CVE-2023-25859 or the next vulnerability affects your stack