What’s Vulnerable › Vulnerabilities
CVE-2023-25929: IBM Cognos Analytics cross-site scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-22 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM Cognos Analytics 11.1 and 11.2 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 247861.
Affected products
- IBM Cognos Analytics: from 11.1.0 before 11.1.7; from 11.2.0 before 11.2.4; 11.1.7, 11.1.7-fixpack1, 11.1.7-fixpack2, 11.1.7-fixpack3, 11.1.7-fixpack4, 11.1.7-fixpack5 (+3) — fixed in 11.1.7, 11.2.4
How to fix
Upgrade to a fixed version: IBM Cognos Analytics 11.1.7, 11.2.4. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/247861
- https://security.netapp.com/advisory/ntap-20230814-0005/
- https://www.ibm.com/support/pages/node/7012621
- https://exchange.xforce.ibmcloud.com/vulnerabilities/247861
- https://security.netapp.com/advisory/ntap-20230814-0005/
- https://www.ibm.com/support/pages/node/7012621
Get alerted when CVE-2023-25929 or the next vulnerability affects your stack