What’s Vulnerable › Vulnerabilities
CVE-2023-25979: WordPress Video Gallery – YouTube Gallery Plugin <= 1.7.6 is vulnerable to Cross Site Scripting (XSS)
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-03 · updated 2026-06-17
- Weakness: CWE-79
Description
Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Video Gallery by Total-Soft Video Gallery plugin <= 1.7.6 versions.
Affected products
- totalsoft Video Gallery – YouTube Gallery, Vimeo, Video Portfolio, Image Portfolio and Image Gallery: before 1.7.7 — fixed in 1.7.7
How to fix
Upgrade to a fixed version: totalsoft Video Gallery – YouTube Gallery, Vimeo, Video Portfolio, Image Portfolio and Image Gallery 1.7.7. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/gallery-videos/wordpress-video-gallery-youtube-gallery-plugin-1-7-6-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/gallery-videos/wordpress-video-gallery-youtube-gallery-plugin-1-7-6-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2023-25979 or the next vulnerability affects your stack