What’s Vulnerable › Vulnerabilities
CVE-2023-2601: WP Brutal AI < 2.0.0 - SQL Injection via CSRF
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-27 · updated 2026-06-17
Description
The wpbrutalai WordPress plugin before 2.0.0 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by admin via CSRF.
Affected products
- wpbrutalai: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: wpbrutalai 2.0.0. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/173732/WordPress-WP-Brutal-AI-Cross-Site-Request-Forgery-SQL-Injection.html
- https://wpscan.com/vulnerability/57769468-3802-4985-bf5e-44ec1d59f5fd
- http://packetstormsecurity.com/files/173732/WordPress-WP-Brutal-AI-Cross-Site-Request-Forgery-SQL-Injection.html
- https://wpscan.com/vulnerability/57769468-3802-4985-bf5e-44ec1d59f5fd
Get alerted when CVE-2023-2601 or the next vulnerability affects your stack