What’s Vulnerable › Vulnerabilities
CVE-2023-26022: IBM Db2 denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-28 · updated 2026-06-17
- Weakness: CWE-20
Description
IBM Db2 for Linux, UNIX and Windows (includes Db2 Connect Server) is vulnerable to a denial of service as the server may crash when an Out of Memory occurs using the DBMS_OUTPUT module. IBM X-Force ID: 247868.
Affected products
- IBM Db2 for Linux, UNIX and Windows: from 11.1 before 11.1.4; from 11.5 before 11.5.8; 10.5, 10.5-fp1, 10.5-fp10, 10.5-fp2, 10.5-fp3, 10.5-fp3a (+13) — fixed in 11.1.4, 11.5.8
How to fix
Upgrade to a fixed version: IBM Db2 for Linux, UNIX and Windows 11.1.4, 11.5.8. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/247868
- https://security.netapp.com/advisory/ntap-20230511-0010/
- https://www.ibm.com/support/pages/node/6985669
- https://exchange.xforce.ibmcloud.com/vulnerabilities/247868
- https://security.netapp.com/advisory/ntap-20230511-0010/
- https://www.ibm.com/support/pages/node/6985669
Get alerted when CVE-2023-26022 or the next vulnerability affects your stack