What’s Vulnerable › Vulnerabilities
CVE-2023-26035: ZoneMinder vulnerable to Missing Authorization
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 80.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-25 · updated 2026-06-17
- Weakness: CWE-862
Description
ZoneMinder is a free, open source Closed-circuit television software application for Linux which supports IP, USB and Analog cameras. Versions prior to 1.36.33 and 1.37.33 are vulnerable to Unauthenticated Remote Code Execution via Missing Authorization. There are no permissions check on the snapshot action, which expects an id to fetch an existing monitor but can be passed an object to create a new one instead. TriggerOn ends up calling shell_exec using the supplied Id. This issue is fixed in This issue is fixed in versions 1.36.33 and 1.37.33.
Affected products
- zoneminder: before 1.36.33; from 1.37.00 before 1.37.33 — fixed in 1.36.33, 1.37.33
How to fix
Upgrade to a fixed version: zoneminder 1.36.33, 1.37.33. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/175675/ZoneMinder-Snapshots-Command-Injection.html
- https://github.com/ZoneMinder/zoneminder/security/advisories/GHSA-72rg-h4vf-29gr
- http://packetstormsecurity.com/files/175675/ZoneMinder-Snapshots-Command-Injection.html
- https://github.com/ZoneMinder/zoneminder/security/advisories/GHSA-72rg-h4vf-29gr
Get alerted when CVE-2023-26035 or the next vulnerability affects your stack