What’s Vulnerable › Vulnerabilities
CVE-2023-26039: ZoneMinder vulnerable to OS Command injection in daemonControl() API
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-25 · updated 2026-06-17
- Weakness: CWE-78
Description
ZoneMinder is a free, open source Closed-circuit television software application for Linux which supports IP, USB and Analog cameras. Versions prior to 1.36.33 and 1.37.33 contain an OS Command Injection via daemonControl() in (/web/api/app/Controller/HostController.php). Any authenticated user can construct an api command to execute any shell command as the web user. This issue is patched in versions 1.36.33 and 1.37.33.
Affected products
- zoneminder: before 1.36.33; from 1.37.00 before 1.37.33 — fixed in 1.36.33, 1.37.33
How to fix
Upgrade to a fixed version: zoneminder 1.36.33, 1.37.33. Check the vendor advisory for mitigations.
References
- https://github.com/ZoneMinder/zoneminder/security/advisories/GHSA-44q8-h2pw-cc9g
- https://github.com/ZoneMinder/zoneminder/security/advisories/GHSA-44q8-h2pw-cc9g
Get alerted when CVE-2023-26039 or the next vulnerability affects your stack