What’s Vulnerable › Vulnerabilities
CVE-2023-26045: NodeBB vulnerable to path traversal and code execution via prototype vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-24 · updated 2026-06-17
- Weakness: CWE-22
Description
NodeBB is Node.js based forum software. Starting in version 2.5.0 and prior to version 2.8.7, due to the use of the object destructuring assignment syntax in the user export code path, combined with a path traversal vulnerability, a specially crafted payload could invoke the user export logic to arbitrarily execute javascript files on the local disk. This issue is patched in version 2.8.7. As a workaround, site maintainers can cherry pick the fix into their codebase to patch the exploit.
Affected products
- NodeBB: from 2.5.0 before 2.8.7 — fixed in 2.8.7
How to fix
Upgrade to a fixed version: NodeBB 2.8.7. Check the vendor advisory for mitigations.
References
- https://github.com/NodeBB/NodeBB/commit/ec58700f6dff8e5b4af1544f6205ec362b593092
- https://github.com/NodeBB/NodeBB/security/advisories/GHSA-vh2g-6c4x-5hmp
- https://security.netapp.com/advisory/ntap-20230831-0004/
- https://github.com/NodeBB/NodeBB/commit/ec58700f6dff8e5b4af1544f6205ec362b593092
- https://github.com/NodeBB/NodeBB/security/advisories/GHSA-vh2g-6c4x-5hmp
- https://security.netapp.com/advisory/ntap-20230831-0004/
Get alerted when CVE-2023-26045 or the next vulnerability affects your stack