What’s Vulnerable › Vulnerabilities
CVE-2023-2605: WP Brutal AI < 2.0.1 - Admin+ Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-27 · updated 2026-06-17
Description
The wpbrutalai WordPress plugin before 2.0.1 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against a logged in high privilege users such as admin.
Affected products
- wpbrutalai: before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: wpbrutalai 2.0.1. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/173734/WordPress-WP-Brutal-AI-Cross-Site-Scripting.html
- https://wpscan.com/vulnerability/372cb940-71ba-4d19-b35a-ab15f8c2fdeb
- http://packetstormsecurity.com/files/173734/WordPress-WP-Brutal-AI-Cross-Site-Scripting.html
- https://wpscan.com/vulnerability/372cb940-71ba-4d19-b35a-ab15f8c2fdeb
Get alerted when CVE-2023-2605 or the next vulnerability affects your stack