What’s Vulnerable › Vulnerabilities
CVE-2023-26053: Gradle usage of long IDs for PGP keys opens potential for collision attacks
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-02 · updated 2026-06-17
- Weakness: CWE-829
Description
Gradle is a build tool with a focus on build automation and support for multi-language development. This is a collision attack on long IDs (64bits) for PGP keys. Users of dependency verification in Gradle are vulnerable if they use long IDs for PGP keys in a `trusted-key` or `pgp` element in their dependency verification metadata file. The fix is to fail dependency verification if anything but a fingerprint is used in a trust element in dependency verification metadata. The problem is fixed in Gradle 8.0 and above. The problem is also patched in Gradle 6.9.4 and 7.6.1. As a workaround, use only full fingerprint IDs for `trusted-key` or `pgp` element in the metadata is a protection against this issue.
Affected products
- gradle: from 6.2.0 before 6.9.4; from 7.0.0 before 7.6.1 — fixed in 6.9.4, 7.6.1
How to fix
Upgrade to a fixed version: gradle 6.9.4, 7.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/gradle/gradle/commit/bf3cc0f2b463033037e67aaacda31291643ea1a9
- https://github.com/gradle/gradle/security/advisories/GHSA-c724-3xg7-g3hf
- https://security.netapp.com/advisory/ntap-20230413-0002/
- https://github.com/gradle/gradle/commit/bf3cc0f2b463033037e67aaacda31291643ea1a9
- https://github.com/gradle/gradle/security/advisories/GHSA-c724-3xg7-g3hf
- https://security.netapp.com/advisory/ntap-20230413-0002/
Get alerted when CVE-2023-26053 or the next vulnerability affects your stack