What’s Vulnerable › Vulnerabilities
CVE-2023-2610: Integer Overflow or Wraparound in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-09 · updated 2026-06-23
- Weakness: CWE-190
Description
Integer Overflow or Wraparound in GitHub repository vim/vim prior to 9.0.1532.
Affected products
- vim/vim: before 9.0.1532 — fixed in 9.0.1532
How to fix
Upgrade to a fixed version: vim/vim 9.0.1532. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/ab9a2d884b3a4abe319606ea95a5a6d6b01cd73a
- https://huntr.dev/bounties/31e67340-935b-4f6c-a923-f7246bc29c7d
- https://lists.debian.org/debian-lts-announce/2023/06/msg00015.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PCLJN4QINITA3ZASKLEJ64C5TFNKELMO/
- https://support.apple.com/kb/HT213844
- https://support.apple.com/kb/HT213845
- https://github.com/vim/vim/commit/ab9a2d884b3a4abe319606ea95a5a6d6b01cd73a
- https://huntr.dev/bounties/31e67340-935b-4f6c-a923-f7246bc29c7d
- https://lists.debian.org/debian-lts-announce/2023/06/msg00015.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00023.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PCLJN4QINITA3ZASKLEJ64C5TFNKELMO/
- https://security.netapp.com/advisory/ntap-20241129-0006/
Get alerted when CVE-2023-2610 or the next vulnerability affects your stack