What’s Vulnerable › Vulnerabilities
CVE-2023-26114
- Severity: critical (CVSS 9.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-23 · updated 2026-06-17
- Weakness: CWE-1385
Description
Versions of the package code-server before 4.10.1 are vulnerable to Missing Origin Validation in WebSockets handshakes. Exploiting this vulnerability can allow an adversary in specific scenarios to access data from and connect to the code-server instance.
Affected products
- code-server: before 4.10.1 — fixed in 4.10.1
How to fix
Upgrade to a fixed version: code-server 4.10.1. Check the vendor advisory for mitigations.
References
- https://github.com/coder/code-server/commit/d477972c68fc8c8e8d610aa7287db87ba90e55c7
- https://github.com/coder/code-server/releases/tag/v4.10.1
- https://security.snyk.io/vuln/SNYK-JS-CODESERVER-3368148
- https://github.com/coder/code-server/commit/d477972c68fc8c8e8d610aa7287db87ba90e55c7
- https://github.com/coder/code-server/releases/tag/v4.10.1
- https://security.snyk.io/vuln/SNYK-JS-CODESERVER-3368148
Get alerted when CVE-2023-26114 or the next vulnerability affects your stack