What’s Vulnerable › Vulnerabilities
CVE-2023-26123
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Versions of the package raysan5/raylib before 4.5.0 are vulnerable to Cross-site Scripting (XSS) such that the SetClipboardText API does not properly escape the ' character, allowing attacker-controlled input to break out of the string and execute arbitrary JavaScript via emscripten_run_script function. **Note:** This vulnerability is present only when compiling raylib for PLATFORM_WEB. All the other Desktop/Mobile/Embedded platforms are not affected.
Affected products
- raysan5 raylib: before 4.5.0 — fixed in 4.5.0
How to fix
Upgrade to a fixed version: raysan5 raylib 4.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/raysan5/raylib/commit/b436c8d7e5346a241b00511a11585936895d959d
- https://github.com/raysan5/raylib/issues/2954
- https://github.com/raysan5/raylib/releases/tag/4.5.0
- https://security.snyk.io/vuln/SNYK-UNMANAGED-RAYSAN5RAYLIB-5421188
- https://github.com/raysan5/raylib/commit/b436c8d7e5346a241b00511a11585936895d959d
- https://github.com/raysan5/raylib/issues/2954
- https://github.com/raysan5/raylib/releases/tag/4.5.0
- https://security.snyk.io/vuln/SNYK-UNMANAGED-RAYSAN5RAYLIB-5421188
Get alerted when CVE-2023-26123 or the next vulnerability affects your stack