What’s Vulnerable › Vulnerabilities
CVE-2023-26132
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-10 · updated 2026-06-17
- Weakness: CWE-1321
Description
Versions of the package dottie before 2.0.4 are vulnerable to Prototype Pollution due to insufficient checks, via the set() function and the current variable in the /dottie.js file.
Affected products
- mickhansen dottie.js: before 2.0.4 — fixed in 2.0.4
How to fix
Upgrade to a fixed version: mickhansen dottie.js 2.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/mickhansen/dottie.js/blob/b48e22714aae4489ea6276452f22cc61980ba5a4/dottie.js%23L107
- https://github.com/mickhansen/dottie.js/commit/7d3aee1c9c3c842720506e131de7e181e5c8db68
- https://security.snyk.io/vuln/SNYK-JS-DOTTIE-3332763
- https://github.com/mickhansen/dottie.js/blob/b48e22714aae4489ea6276452f22cc61980ba5a4/dottie.js%23L107
- https://github.com/mickhansen/dottie.js/commit/7d3aee1c9c3c842720506e131de7e181e5c8db68
- https://security.snyk.io/vuln/SNYK-JS-DOTTIE-3332763
Get alerted when CVE-2023-26132 or the next vulnerability affects your stack