What’s Vulnerable › Vulnerabilities
CVE-2023-26141: sidekiq Denial of Service vulnerability
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-14 · updated 2026-06-17
- Weakness: CWE-400
Description
Versions of the package sidekiq before 7.1.3 are vulnerable to Denial of Service (DoS) due to insufficient checks in the dashboard-charts.js file. An attacker can exploit this vulnerability by manipulating the localStorage value which will cause excessive polling requests.
Affected products
- sidekiq/sidekiq: before 6.5.10; from 7.0 before 7.1.3 — fixed in 6.5.10, 7.1.3
- Rubygems Sidekiq: from 7.0.0 before 7.1.3; before 6.5.10; 7.0.0, 7.0.1, 7.0.2, 7.0.3, 7.0.4, 7.0.5 (+191) — fixed in 7.1.3, 6.5.10
How to fix
Upgrade to a fixed version: sidekiq/sidekiq 6.5.10, 7.1.3; Rubygems Sidekiq 7.1.3, 6.5.10. Check the vendor advisory for mitigations.
References
- https://gist.github.com/keeganparr1/1dffd3c017339b7ed5371ed3d81e6b2a
- https://github.com/sidekiq/sidekiq/blob/6-x/web/assets/javascripts/dashboard.js%23L6
- https://github.com/sidekiq/sidekiq/commit/62c90d7c5a7d8a378d79909859d87c2e0702bf89
- https://security.snyk.io/vuln/SNYK-RUBY-SIDEKIQ-5885107
- https://gist.github.com/keeganparr1/1dffd3c017339b7ed5371ed3d81e6b2a
- https://github.com/sidekiq/sidekiq/blob/6-x/web/assets/javascripts/dashboard.js%23L6
- https://github.com/sidekiq/sidekiq/commit/62c90d7c5a7d8a378d79909859d87c2e0702bf89
- https://security.snyk.io/vuln/SNYK-RUBY-SIDEKIQ-5885107
Get alerted when CVE-2023-26141 or the next vulnerability affects your stack