What’s Vulnerable › Vulnerabilities
CVE-2023-26142
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-12 · updated 2026-10-29
- Weakness: CWE-113
Description
All versions of the package crow are vulnerable to HTTP Response Splitting when untrusted user input is used to build header values. Header values are not properly sanitized against CRLF Injection in the set_header and add_header functions. An attacker can add the \r\n (carriage return line feeds) characters to end the HTTP response headers and inject malicious content.
Affected products
- Crow: before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: Crow 1.3.2. Check the vendor advisory for mitigations.
References
- https://gist.github.com/dellalibera/9247769cc90ed96c0d72ddbcba88c65c
- https://security.snyk.io/vuln/SNYK-UNMANAGED-CROW-5665556
- https://gist.github.com/dellalibera/9247769cc90ed96c0d72ddbcba88c65c
- https://security.snyk.io/vuln/SNYK-UNMANAGED-CROW-5665556
Get alerted when CVE-2023-26142 or the next vulnerability affects your stack