What’s Vulnerable › Vulnerabilities
CVE-2023-26143
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-19 · updated 2026-06-17
- Weakness: CWE-88
Description
Versions of the package blamer before 1.0.4 are vulnerable to Arbitrary Argument Injection via the blameByFile() API. The library does not sanitize for user input or validate the given file path conforms to a specific schema, nor does it properly pass command-line flags to the git binary using the double-dash POSIX characters (--) to communicate the end of options.
Affected products
- blamer: before 1.0.4 — fixed in 1.0.4
How to fix
Upgrade to a fixed version: blamer 1.0.4. Check the vendor advisory for mitigations.
References
- https://gist.github.com/lirantal/14c3686370a86461f555d3f0703e02f9
- https://github.com/kucherenko/blamer/commit/0965877f115753371a2570f10a63c455d2b2cde3
- https://security.snyk.io/vuln/SNYK-JS-BLAMER-5731318
- https://gist.github.com/lirantal/14c3686370a86461f555d3f0703e02f9
- https://github.com/kucherenko/blamer/commit/0965877f115753371a2570f10a63c455d2b2cde3
- https://security.snyk.io/vuln/SNYK-JS-BLAMER-5731318
Get alerted when CVE-2023-26143 or the next vulnerability affects your stack