What’s Vulnerable › Vulnerabilities
CVE-2023-26144
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-20 · updated 2026-06-17
- Weakness: CWE-400
Description
Versions of the package graphql from 16.3.0 and before 16.8.1 are vulnerable to Denial of Service (DoS) due to insufficient checks in the OverlappingFieldsCanBeMergedRule.ts file when parsing large queries. This vulnerability allows an attacker to degrade system performance. **Note:** It was not proven that this vulnerability can crash the process.
Affected products
- graphql: from 16.3.0 before 16.8.1; 17.0.0-alpha1, 17.0.0-alpha2 — fixed in 16.8.1
How to fix
Upgrade to a fixed version: graphql 16.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/graphql/graphql-js/commit/f94b511386c7e47bd0380dcd56553dc063320226
- https://github.com/graphql/graphql-js/issues/3955
- https://github.com/graphql/graphql-js/pull/3972
- https://github.com/graphql/graphql-js/releases/tag/v16.8.1
- https://security.snyk.io/vuln/SNYK-JS-GRAPHQL-5905181
- https://github.com/graphql/graphql-js/commit/f94b511386c7e47bd0380dcd56553dc063320226
- https://github.com/graphql/graphql-js/issues/3955
- https://github.com/graphql/graphql-js/pull/3972
- https://github.com/graphql/graphql-js/releases/tag/v16.8.1
- https://security.snyk.io/vuln/SNYK-JS-GRAPHQL-5905181
Get alerted when CVE-2023-26144 or the next vulnerability affects your stack