What’s Vulnerable › Vulnerabilities
CVE-2023-26149
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-28 · updated 2026-06-17
- Weakness: CWE-79
Description
Versions of the package quill-mention before 4.0.0 are vulnerable to Cross-site Scripting (XSS) due to improper user-input sanitization, via the renderList function. **Note:** If the mentions list is sourced from unsafe (user-sourced) data, this might allow an injection attack when a Quill user hits @.
Affected products
- quill-mention: before 4.0.0 — fixed in 4.0.0
How to fix
Upgrade to a fixed version: quill-mention 4.0.0. Check the vendor advisory for mitigations.
References
- https://codepen.io/ALiangLiang/pen/mdQMJXK
- https://github.com/quill-mention/quill-mention/blob/0aa9847719257496b14ac5401872c4e2ffcbc3d1/src/quill.mention.js%23L391
- https://github.com/quill-mention/quill-mention/commit/e85262ddced0a7f0b6fc8350d236a68bd1e28385
- https://github.com/quill-mention/quill-mention/issues/255
- https://github.com/quill-mention/quill-mention/pull/341
- https://security.snyk.io/vuln/SNYK-JS-QUILLMENTION-5921549
- https://codepen.io/ALiangLiang/pen/mdQMJXK
- https://github.com/quill-mention/quill-mention/blob/0aa9847719257496b14ac5401872c4e2ffcbc3d1/src/quill.mention.js%23L391
- https://github.com/quill-mention/quill-mention/commit/e85262ddced0a7f0b6fc8350d236a68bd1e28385
- https://github.com/quill-mention/quill-mention/issues/255
- https://github.com/quill-mention/quill-mention/pull/341
- https://security.snyk.io/vuln/SNYK-JS-QUILLMENTION-5921549
Get alerted when CVE-2023-26149 or the next vulnerability affects your stack