What’s Vulnerable › Vulnerabilities
CVE-2023-26153
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-06 · updated 2026-06-17
- Weakness: CWE-78
Description
Versions of the package geokit-rails before 2.5.0 are vulnerable to Command Injection due to unsafe deserialisation of YAML within the 'geo_location' cookie. This issue can be exploited remotely via a malicious cookie value. **Note:** An attacker can use this vulnerability to execute commands on the host system.
Affected products
- geokit-rails: before 2.5.0 — fixed in 2.5.0
How to fix
Upgrade to a fixed version: geokit-rails 2.5.0. Check the vendor advisory for mitigations.
References
- https://gist.github.com/CalumHutton/b7aa1c2e71c8d4386463ac14f686901d
- https://github.com/geokit/geokit-rails/blob/master/lib/geokit-rails/ip_geocode_lookup.rb%23L37
- https://github.com/geokit/geokit-rails/commit/7ffc5813e57f6f417987043e1039925fd0865c43
- https://github.com/geokit/geokit-rails/commit/a93dfe49fb9aeae7164e2f8c4041450a04b5482f
- https://security.snyk.io/vuln/SNYK-RUBY-GEOKITRAILS-5920323
- https://gist.github.com/CalumHutton/b7aa1c2e71c8d4386463ac14f686901d
- https://github.com/geokit/geokit-rails/blob/master/lib/geokit-rails/ip_geocode_lookup.rb%23L37
- https://github.com/geokit/geokit-rails/commit/7ffc5813e57f6f417987043e1039925fd0865c43
- https://github.com/geokit/geokit-rails/commit/a93dfe49fb9aeae7164e2f8c4041450a04b5482f
- https://security.snyk.io/vuln/SNYK-RUBY-GEOKITRAILS-5920323
Get alerted when CVE-2023-26153 or the next vulnerability affects your stack