What’s Vulnerable › Vulnerabilities
CVE-2023-26156
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-09 · updated 2026-06-17
- Weakness: CWE-78
Description
Versions of the package chromedriver before 119.0.1 are vulnerable to Command Injection when setting the chromedriver.path to an arbitrary system binary. This could lead to unauthorized access and potentially malicious actions on the host system. **Note:** An attacker must have access to the system running the vulnerable chromedriver library to exploit it. The success of exploitation also depends on the permissions and privileges of the process running chromedriver.
Affected products
- chromedriver: before 119.0.1 — fixed in 119.0.1
How to fix
Upgrade to a fixed version: chromedriver 119.0.1. Check the vendor advisory for mitigations.
References
- https://gist.github.com/mcoimbra/47b1da554a80795c45126d51e41b2b18
- https://github.com/giggio/node-chromedriver/commit/de961e34e023afcf4fa5c0faeeec69aaa6c3c815
- https://security.snyk.io/vuln/SNYK-JS-CHROMEDRIVER-6049539
- https://gist.github.com/mcoimbra/47b1da554a80795c45126d51e41b2b18
- https://github.com/giggio/node-chromedriver/commit/de961e34e023afcf4fa5c0faeeec69aaa6c3c815
- https://security.snyk.io/vuln/SNYK-JS-CHROMEDRIVER-6049539
Get alerted when CVE-2023-26156 or the next vulnerability affects your stack