What’s Vulnerable › Vulnerabilities
CVE-2023-26157
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-02 · updated 2026-06-17
- Weakness: CWE-400
Description
Versions of the package libredwg before 0.12.5.6384 are vulnerable to Denial of Service (DoS) due to an out-of-bounds read involving section->num_pages in decode_r2007.c.
Affected products
- GNU LibreDWG: before 0.12.5.6384 — fixed in 0.12.5.6384
How to fix
Upgrade to a fixed version: GNU LibreDWG 0.12.5.6384. Check the vendor advisory for mitigations.
References
- https://github.com/LibreDWG/libredwg/commit/c8cf03ce4c2315b146caf582ea061c0460193bcc
- https://github.com/LibreDWG/libredwg/issues/850
- https://security.snyk.io/vuln/SNYK-UNMANAGED-LIBREDWG-6070730
- https://github.com/LibreDWG/libredwg/commit/c8cf03ce4c2315b146caf582ea061c0460193bcc
- https://github.com/LibreDWG/libredwg/issues/850
- https://security.snyk.io/vuln/SNYK-UNMANAGED-LIBREDWG-6070730
Get alerted when CVE-2023-26157 or the next vulnerability affects your stack