What’s Vulnerable › Vulnerabilities
CVE-2023-2618: OpenCV wechat_qrcode Module decoded_bit_stream_parser.cpp decodeHanziSegment memory leak
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-10 · updated 2026-06-17
- Weakness: CWE-401
Description
A vulnerability, which was classified as problematic, has been found in OpenCV wechat_qrcode Module up to 4.7.0. Affected by this issue is the function DecodedBitStreamParser::decodeHanziSegment of the file qrcode/decoder/decoded_bit_stream_parser.cpp. The manipulation leads to memory leak. The attack may be launched remotely. The name of the patch is 2b62ff6181163eea029ed1cab11363b4996e9cd6. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-228548.
Affected products
- OpenCV 3.0.0: from 4.5.2 before 4.8.0 — fixed in 4.8.0
How to fix
Upgrade to a fixed version: OpenCV 3.0.0 4.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/opencv/opencv_contrib/pull/3484
- https://github.com/opencv/opencv_contrib/pull/3484/commits/2b62ff6181163eea029ed1cab11363b4996e9cd6
- https://vuldb.com/?ctiid.228548
- https://vuldb.com/?id.228548
- https://github.com/opencv/opencv_contrib/pull/3484
- https://github.com/opencv/opencv_contrib/pull/3484/commits/2b62ff6181163eea029ed1cab11363b4996e9cd6
- https://vuldb.com/?ctiid.228548
- https://vuldb.com/?id.228548
Get alerted when CVE-2023-2618 or the next vulnerability affects your stack