What’s Vulnerable › Vulnerabilities
CVE-2023-26267
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-21 · updated 2026-06-17
- Weakness: CWE-611
Description
php-saml-sp before 1.1.1 and 2.x before 2.1.1 allows reading arbitrary files as the webserver user because resolving XML external entities was silently enabled via \LIBXML_DTDLOAD | \LIBXML_DTDATTR.
Affected products
- Php-Saml-Sp Project Php-Saml-Sp: before 1.1.1; from 2.0.0 before 2.1.1 — fixed in 1.1.1, 2.1.1
How to fix
Upgrade to a fixed version: Php-Saml-Sp Project Php-Saml-Sp 1.1.1, 2.1.1. Check the vendor advisory for mitigations.
References
- https://git.sr.ht/~fkooman/php-saml-sp/commit/851f75b298a77e62d9022f1b170f662f5f7716d6
- https://git.sr.ht/~fkooman/php-saml-sp/log
- https://git.sr.ht/~fkooman/php-saml-sp/commit/851f75b298a77e62d9022f1b170f662f5f7716d6
- https://git.sr.ht/~fkooman/php-saml-sp/log
Get alerted when CVE-2023-26267 or the next vulnerability affects your stack