What’s Vulnerable › Vulnerabilities
CVE-2023-26269: Apache James server: Privilege escalation through unauthenticated JMX
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-03 · updated 2026-06-17
- Weakness: CWE-862
Description
Apache James server version 3.7.3 and earlier provides a JMX management service without authentication by default. This allows privilege escalation by a malicious local user. Administrators are advised to disable JMX, or set up a JMX password. Note that version 3.7.4 onward will set up a JMX password automatically for Guice users.
Affected products
- Apache Software Foundation Apache James: before 3.7.4 — fixed in 3.7.4
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache James 3.7.4. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/04/18/3
- https://lists.apache.org/thread/2z44rg93pflbjhvbwy3xtz505bx41cbs
- http://www.openwall.com/lists/oss-security/2023/04/18/3
- https://lists.apache.org/thread/2z44rg93pflbjhvbwy3xtz505bx41cbs
Get alerted when CVE-2023-26269 or the next vulnerability affects your stack