What’s Vulnerable › Vulnerabilities
CVE-2023-2628: KiviCare Management System < 3.2.1 - Multiple CSRF
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-27 · updated 2026-06-17
Description
The KiviCare WordPress plugin before 3.2.1 does not have CSRF checks (either flawed or missing completely) in various AJAX actions, which could allow attackers to make logged in users perform unwanted actions via CSRF attacks. This includes, but is not limited to: Delete arbitrary appointments/medical records/etc, create/update various users (patients, doctors etc)
Affected products
- iqonicdesign KiviCare – Clinic & Patient Management System (EHR): before 3.2.1 — fixed in 3.2.1
How to fix
Upgrade to a fixed version: iqonicdesign KiviCare – Clinic & Patient Management System (EHR) 3.2.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e0741e2c-c529-4815-8744-16e01cdb0aed
- https://wpscan.com/vulnerability/e0741e2c-c529-4815-8744-16e01cdb0aed
Get alerted when CVE-2023-2628 or the next vulnerability affects your stack