What’s Vulnerable › Vulnerabilities
CVE-2023-26285: IBM MQ denial of service
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-05 · updated 2026-06-17
- Weakness: CWE-119
Description
IBM MQ 9.2 CD, 9.2 LTS, 9.3 CD, and 9.3 LTS could allow a remote attacker to cause a denial of service due to an error processing invalid data. IBM X-Force ID: 248418.
Affected products
- IBM MQ Appliance: from 9.2.0.0 before 9.2.0.11; from 9.2.0.0 before 9.2.5.7; from 9.3.0.0 before 9.3.0.5; from 9.3.0.0 before 9.3.2.1 — fixed in 9.2.0.11, 9.2.5.7, 9.3.0.5, 9.3.2.1
How to fix
Upgrade to a fixed version: IBM MQ Appliance 9.2.0.11, 9.2.5.7, 9.3.0.5, 9.3.2.1. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/248418
- https://www.ibm.com/support/pages/node/6986563
- https://exchange.xforce.ibmcloud.com/vulnerabilities/248418
- https://www.ibm.com/support/pages/node/6986563
Get alerted when CVE-2023-26285 or the next vulnerability affects your stack