What’s Vulnerable › Vulnerabilities
CVE-2023-26302: markdown-it-py CLI crash on invalid UTF-8 characters
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-22 · updated 2026-06-17
- Weakness: CWE-173
Description
Denial of service could be caused to the command line interface of markdown-it-py, before v2.2.0, if an attacker was allowed to use invalid UTF-8 characters as input.
Affected products
- Executable Books markdown-it-py: before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: Executable Books markdown-it-py 2.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/executablebooks/markdown-it-py/commit/53ca3e9c2b9e9b295f6abf7f4ad2730a9b70f68c
- https://github.com/executablebooks/markdown-it-py/commit/53ca3e9c2b9e9b295f6abf7f4ad2730a9b70f68c
Get alerted when CVE-2023-26302 or the next vulnerability affects your stack