What’s Vulnerable › Vulnerabilities
CVE-2023-26370: ZDI-CAN-21257: Adobe Photoshop PSD File Parsing Uninitialized Variable Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-11 · updated 2026-06-17
- Weakness: CWE-824
Description
Adobe Photoshop versions 23.5.5 (and earlier) and 24.7 (and earlier) are affected by an Access of Uninitialized Pointer vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Photoshop 2022: through 23.5.5
- Adobe Photoshop 2023: before 24.7.1 — fixed in 24.7.1
- Adobe Photoshop 2024: before 25.0 — fixed in 25.0
How to fix
Upgrade to a fixed version: Adobe Photoshop 2023 24.7.1; Adobe Photoshop 2024 25.0. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/photoshop/apsb23-51.html
- https://helpx.adobe.com/security/products/photoshop/apsb23-51.html
Get alerted when CVE-2023-26370 or the next vulnerability affects your stack