What’s Vulnerable › Vulnerabilities
CVE-2023-26464: Apache Log4j 1.x (EOL) allows DoS in Chainsaw and SocketAppender
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-10 · updated 2026-06-17
- Weakness: CWE-502
Description
** UNSUPPORTED WHEN ASSIGNED ** When using the Chainsaw or SocketAppender components with Log4j 1.x on JRE less than 1.7, an attacker that manages to cause a logging entry involving a specially-crafted (ie, deeply nested) hashmap or hashtable (depending on which logging component is in use) to be processed could exhaust the available memory in the virtual machine and achieve Denial of Service when the object is deserialized. This issue affects Apache Log4j before 2. Affected users are recommended to update to Log4j 2.x. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.
Affected products
- Apache Log4j: from 1.0.4 before 2.0 — fixed in 2.0
How to fix
Upgrade to a fixed version: Apache Log4j 2.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/wkx6grrcjkh86crr49p4blc1v1nflj3t
- https://security.netapp.com/advisory/ntap-20230505-0008/
- https://lists.apache.org/thread/wkx6grrcjkh86crr49p4blc1v1nflj3t
- https://security.netapp.com/advisory/ntap-20230505-0008/
Get alerted when CVE-2023-26464 or the next vulnerability affects your stack