What’s Vulnerable › Vulnerabilities
CVE-2023-26480: XWiki-Platform vulnerable to stored Cross-site Scripting via the HTML displayer in Live Data
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-02 · updated 2026-06-17
- Weakness: CWE-79
Description
XWiki Platform is a generic wiki platform. Starting in version 12.10, a user without script rights can introduce a stored cross-site scripting by using the Live Data macro. This has been patched in XWiki 14.9, 14.4.7, and 13.10.10. There are no known workarounds.
Affected products
- xwiki-platform: from 12.10 before 13.10.10; from 14.0 before 14.4.7; from 14.5 before 14.9; 14.9-rc1 — fixed in 13.10.10, 14.4.7, 14.9
How to fix
Upgrade to a fixed version: xwiki-platform 13.10.10, 14.4.7, 14.9. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/23d5ea9b23e84b5f3d1f1b2d5673fe8c774d0d79
- https://github.com/xwiki/xwiki-platform/commit/556e7823260b826f344c1a6e95d935774587e028
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-32fq-m2q5-h83g
- https://jira.xwiki.org/browse/XWIKI-20143
- https://github.com/xwiki/xwiki-platform/commit/23d5ea9b23e84b5f3d1f1b2d5673fe8c774d0d79
- https://github.com/xwiki/xwiki-platform/commit/556e7823260b826f344c1a6e95d935774587e028
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-32fq-m2q5-h83g
- https://jira.xwiki.org/browse/XWIKI-20143
Get alerted when CVE-2023-26480 or the next vulnerability affects your stack