What’s Vulnerable › Vulnerabilities
CVE-2023-26482: Scope of workflow operations is not validated in nextcloud server
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-30 · updated 2026-06-17
- Weakness: CWE-78
Description
Nextcloud server is an open source home cloud implementation. In affected versions a missing scope validation allowed users to create workflows which are designed to be only available for administrators. Some workflows are designed to be RCE by invoking defined scripts, in order to generate PDFs, invoking webhooks or running scripts on the server. Due to this combination depending on the available apps the issue can result in a RCE at the end. It is recommended that the Nextcloud Server is upgraded to 24.0.10 or 25.0.4. Users unable to upgrade should disable app `workflow_scripts` and `workflow_pdf_converter` as a mitigation.
Affected products
- Nextcloud Server: from 18.0.0 before 20.0.14.12; from 21.0.0 before 21.0.9.10; from 22.0.0 before 22.2.10.10; from 23.0.0 before 23.0.12.5; from 24.0.0 before 24.0.10; from 25.0.0 before 25.0.4 — fixed in 20.0.14.12, 21.0.9.10, 22.2.10.10, 23.0.12.5, 24.0.10, 25.0.4
How to fix
Upgrade to a fixed version: Nextcloud Server 20.0.14.12, 21.0.9.10, 22.2.10.10, 23.0.12.5. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-h3c9-cmh8-7qpj
- https://github.com/nextcloud/server/commit/5a06b50b10cc9278bbe68bbf897a0c4aeb0c4e60
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-h3c9-cmh8-7qpj
- https://github.com/nextcloud/server/commit/5a06b50b10cc9278bbe68bbf897a0c4aeb0c4e60
Get alerted when CVE-2023-26482 or the next vulnerability affects your stack