What’s Vulnerable › Vulnerabilities
CVE-2023-26488: OpenZeppelin Contracts contains Incorrect Calculation
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-03 · updated 2026-06-17
- Weakness: CWE-682
Description
OpenZeppelin Contracts is a library for secure smart contract development. The ERC721Consecutive contract designed for minting NFTs in batches does not update balances when a batch has size 1 and consists of a single token. Subsequent transfers from the receiver of that token may overflow the balance as reported by `balanceOf`. The issue exclusively presents with batches of size 1. The issue has been patched in 4.8.2.
Affected products
- openzeppelin-contracts: from 4.8.0 before 4.8.2 — fixed in 4.8.2
- OpenZeppelin Contracts Upgradeable: from 4.8.0 before 4.8.2 — fixed in 4.8.2
How to fix
Upgrade to a fixed version: openzeppelin-contracts 4.8.2; OpenZeppelin Contracts Upgradeable 4.8.2. Check the vendor advisory for mitigations.
References
- https://github.com/OpenZeppelin/openzeppelin-contracts/commit/167bf67ed3907f4a674043496019fa346cee7705
- https://github.com/OpenZeppelin/openzeppelin-contracts/releases/tag/v4.8.2
- https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-878m-3g6q-594q
- https://github.com/OpenZeppelin/openzeppelin-contracts/commit/167bf67ed3907f4a674043496019fa346cee7705
- https://github.com/OpenZeppelin/openzeppelin-contracts/releases/tag/v4.8.2
- https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-878m-3g6q-594q
Get alerted when CVE-2023-26488 or the next vulnerability affects your stack