What’s Vulnerable › Vulnerabilities
CVE-2023-26964: h2 vulnerable to denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-11 · updated 2026-06-17
- Weakness: CWE-770
Description
An issue was discovered in hyper v0.13.7. h2-0.2.4 Stream stacking occurs when the H2 component processes HTTP2 RST_STREAM frames. As a result, the memory and CPU usage are high which can lead to a Denial of Service (DoS).
Affected products
- Hyper H2: 0.2.4
- hyperium hyper: 0.13.7
- Crates.Io H2: from 0.0.0-0 before 0.3.17 — fixed in 0.3.17
How to fix
Upgrade to a fixed version: Crates.Io H2 0.3.17. Check the vendor advisory for mitigations.
References
- https://github.com/hyperium/hyper/issues/2877
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZHBAE7LQARMPUEEV4TWET4D7G6WCWBUD/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZYRZ5Y2ALATKKPIITAFAJIS4TR4LUAHO/
- https://github.com/hyperium/hyper/issues/2877
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZHBAE7LQARMPUEEV4TWET4D7G6WCWBUD/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZYRZ5Y2ALATKKPIITAFAJIS4TR4LUAHO/
Get alerted when CVE-2023-26964 or the next vulnerability affects your stack