What’s Vulnerable › Vulnerabilities
CVE-2023-2701: Gravity Forms < 2.7.5 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-17 · updated 2026-06-17
Description
The Gravity Forms WordPress plugin before 2.7.5 does not escape generated URLs before outputting them in attributes, leading to Reflected Cross-Site Scripting which could be used against high-privileged users such as admin.
Affected products
- gravityforms: before 2.7.5 — fixed in 2.7.5
How to fix
Upgrade to a fixed version: gravityforms 2.7.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/298fbe34-62c2-4e56-9bdb-90da570c5bbe
- https://wpscan.com/vulnerability/298fbe34-62c2-4e56-9bdb-90da570c5bbe
Get alerted when CVE-2023-2701 or the next vulnerability affects your stack