What’s Vulnerable › Vulnerabilities
CVE-2023-27033
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-07 · updated 2026-06-17
- Weakness: CWE-434
Description
Prestashop cdesigner v3.1.3 to v3.1.8 was discovered to contain a code injection vulnerability via the component CdesignerSaverotateModuleFrontController::initContent().
Affected products
- Cdesigner Project Cdesigner: from 3.1.3 before 3.2.2 — fixed in 3.2.2
How to fix
Upgrade to a fixed version: Cdesigner Project Cdesigner 3.2.2. Check the vendor advisory for mitigations.
References
- https://addons.prestashop.com/fr/declinaisons-personnalisation/22677-personnalisation-de-produit-product-customize.html
- https://friends-of-presta.github.io/security-advisories/modules/2023/04/06/cdesigner-CWE434.html
- https://addons.prestashop.com/fr/declinaisons-personnalisation/22677-personnalisation-de-produit-product-customize.html
- https://friends-of-presta.github.io/security-advisories/modules/2023/04/06/cdesigner-CWE434.html
Get alerted when CVE-2023-27033 or the next vulnerability affects your stack