What’s Vulnerable › Vulnerabilities
CVE-2023-2705: Appointment booking addon for Gravity Forms < 1.10.0 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-11 · updated 2026-06-17
Description
The gAppointments WordPress plugin before 1.10.0 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against admin
Affected products
- gAppointments: before 1.10.0 — fixed in 1.10.0
How to fix
Upgrade to a fixed version: gAppointments 1.10.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0b3c83ad-d490-4ca3-8589-39163ea5e24b
- https://wpscan.com/vulnerability/0b3c83ad-d490-4ca3-8589-39163ea5e24b
Get alerted when CVE-2023-2705 or the next vulnerability affects your stack