What’s Vulnerable › Vulnerabilities
CVE-2023-2710: video carousel slider with lightbox <= 1.0.22 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The video carousel slider with lightbox plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the search_term parameter in versions up to, and including, 1.0.22 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. CVE-2023-32797 may be a duplicate of this.
Affected products
- nik00726 video carousel slider with lightbox: before 1.0.23 — fixed in 1.0.23
How to fix
Upgrade to a fixed version: nik00726 video carousel slider with lightbox 1.0.23. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/wp-responsive-video-gallery-with-lightbox/wordpress-video-carousel-slider-with-lightbox-plugin-1-0-22-cross-site-scripting-xss-vulnerability
- https://plugins.trac.wordpress.org/browser/wp-responsive-video-gallery-with-lightbox/tags/1.0.22/wp-responsive-video-gallery-with-lightbox.php#L1023
- https://plugins.trac.wordpress.org/browser/wp-responsive-video-gallery-with-lightbox/tags/1.0.23/wp-responsive-video-gallery-with-lightbox.php#L1023
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e88bb3a8-de24-46fb-a3e4-9ca3fdd4cca7?source=cve
- https://plugins.trac.wordpress.org/browser/wp-responsive-video-gallery-with-lightbox/tags/1.0.22/wp-responsive-video-gallery-with-lightbox.php#L1023
- https://plugins.trac.wordpress.org/browser/wp-responsive-video-gallery-with-lightbox/tags/1.0.23/wp-responsive-video-gallery-with-lightbox.php#L1023
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e88bb3a8-de24-46fb-a3e4-9ca3fdd4cca7?source=cve
Get alerted when CVE-2023-2710 or the next vulnerability affects your stack