What’s Vulnerable › Vulnerabilities
CVE-2023-27285: IBM Aspera buffer overflow
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-05 · updated 2026-06-17
- Weakness: CWE-119
Description
IBM Aspera Connect 4.2.5 and IBM Aspera Cargo 4.2.5 is vulnerable to a buffer overflow, caused by improper bounds checking. An attacker could overflow a buffer and execute arbitrary code on the system. IBM X-Force ID: 248625.
Affected products
- IBM Aspera Cargo: before 4.2.6 — fixed in 4.2.6
- IBM Aspera Connect: before 4.2.6 — fixed in 4.2.6
How to fix
Upgrade to a fixed version: IBM Aspera Cargo 4.2.6; IBM Aspera Connect 4.2.6. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/248625
- https://www.ibm.com/support/pages/node/7001053
- https://exchange.xforce.ibmcloud.com/vulnerabilities/248625
- https://www.ibm.com/support/pages/node/7001053
Get alerted when CVE-2023-27285 or the next vulnerability affects your stack