What’s Vulnerable › Vulnerabilities
CVE-2023-27335: Softing edgeAggregator Client Cross-Site Scripting Remote Code Execution Vulnerability
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-79
Description
Softing edgeAggregator Client Cross-Site Scripting Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Softing edgeAggregator. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the handling of the input parameters provided to the edgeAggregetor client. The issue results from the lack of proper validation of user-supplied data, which can lead to the injection of an arbitrary script. An attacker can leverage this in conjunction with other vulnerabilities to execute arbitrary code in the context of root. Was ZDI-CAN-20504.
Affected products
- Softing edgeAggregator: before 3.70 — fixed in 3.70
- Softing Secure Integration Server: before 1.30 — fixed in 1.30
How to fix
Upgrade to a fixed version: Softing edgeAggregator 3.70; Softing Secure Integration Server 1.30. Check the vendor advisory for mitigations.
References
- https://www.zerodayinitiative.com/advisories/ZDI-23-1057/
- https://www.zerodayinitiative.com/advisories/ZDI-23-1057/
Get alerted when CVE-2023-27335 or the next vulnerability affects your stack