What’s Vulnerable › Vulnerabilities
CVE-2023-27358: NETGEAR RAX30 SOAP Request SQL Injection Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-89
Description
NETGEAR RAX30 SOAP Request SQL Injection Remote Code Execution Vulnerability. This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of NETGEAR RAX30 routers. Authentication is not required to exploit this vulnerability. The specific flaw exists within the handling of specific SOAP requests. The issue results from the lack of proper validation of a user-supplied string before using it to construct SQL queries. An attacker can leverage this in conjunction with other vulnerabilities to execute arbitrary code in the context of the service account. Was ZDI-CAN-19754.
Affected products
- NETGEAR RAX30: before 1.0.10.94 — fixed in 1.0.10.94
- NETGEAR Rax35 Firmware: before 1.0.10.94 — fixed in 1.0.10.94
- NETGEAR Rax38 Firmware: before 1.0.10.94 — fixed in 1.0.10.94
- NETGEAR Rax40 Firmware: before 1.0.10.94 — fixed in 1.0.10.94
- NETGEAR Raxe300 Firmware: before 1.0.10.94 — fixed in 1.0.10.94
How to fix
Upgrade to a fixed version: NETGEAR RAX30 1.0.10.94; NETGEAR Rax35 Firmware 1.0.10.94; NETGEAR Rax38 Firmware 1.0.10.94; NETGEAR Rax40 Firmware 1.0.10.94; NETGEAR Raxe300 Firmware 1.0.10.94. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000065617/Security-Advisory-for-Authentication-Bypass-on-Some-Routers-PSV-2022-0349
- https://www.zerodayinitiative.com/advisories/ZDI-23-502/
- https://kb.netgear.com/000065617/Security-Advisory-for-Authentication-Bypass-on-Some-Routers-PSV-2022-0349
- https://www.zerodayinitiative.com/advisories/ZDI-23-502/
Get alerted when CVE-2023-27358 or the next vulnerability affects your stack