What’s Vulnerable › Vulnerabilities
CVE-2023-27360: NETGEAR RAX30 lighttpd Misconfiguration Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-345
Description
NETGEAR RAX30 lighttpd Misconfiguration Remote Code Execution Vulnerability. This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of NETGEAR RAX30. Authentication is not required to exploit this vulnerability. The specific flaw exists within the configuration of the lighttpd HTTP server. The issue results from allowing execution of files from untrusted sources. An attacker can leverage this vulnerability to execute code in the context of root. Was ZDI-CAN-19398.
Affected products
- NETGEAR RAX30: before 1.0.10.94 — fixed in 1.0.10.94
How to fix
Upgrade to a fixed version: NETGEAR RAX30 1.0.10.94. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000065559/Security-Advisory-for-Multiple-Vulnerabilities-on-the-RAX30-PSV-2022-0352
- https://www.zerodayinitiative.com/advisories/ZDI-23-496/
- https://kb.netgear.com/000065559/Security-Advisory-for-Multiple-Vulnerabilities-on-the-RAX30-PSV-2022-0352
- https://www.zerodayinitiative.com/advisories/ZDI-23-496/
Get alerted when CVE-2023-27360 or the next vulnerability affects your stack