What’s Vulnerable › Vulnerabilities
CVE-2023-27362: 3CX Uncontrolled Search Path Local Privilege Escalation Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-427
Description
3CX Uncontrolled Search Path Local Privilege Escalation Vulnerability. This vulnerability allows local attackers to escalate privileges on affected installations of 3CX. An attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability. The specific flaw exists within the configuration of OpenSSL. The product loads an OpenSSL configuration file from an unsecured location. An attacker can leverage this vulnerability to escalate privileges and execute arbitrary code in the context of SYSTEM. Was ZDI-CAN-20026.
Affected products
- 3CX: from 18.0.0.451 before 18.0.8.917 — fixed in 18.0.8.917
How to fix
Upgrade to a fixed version: 3CX 18.0.8.917. Check the vendor advisory for mitigations.
References
- https://www.3cx.com/blog/releases/v18-u8/
- https://www.zerodayinitiative.com/advisories/ZDI-23-1153/
- https://www.3cx.com/blog/releases/v18-u8/
- https://www.zerodayinitiative.com/advisories/ZDI-23-1153/
Get alerted when CVE-2023-27362 or the next vulnerability affects your stack