What’s Vulnerable › Vulnerabilities
CVE-2023-27367: NETGEAR RAX30 libcms_cli Command Injection Remote Code Execution Vulnerability
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-78
Description
NETGEAR RAX30 libcms_cli Command Injection Remote Code Execution Vulnerability. This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of NETGEAR RAX30 routers. Although authentication is required to exploit this vulnerability, the existing authentication mechanism can be bypassed. The specific flaw exists within the libcms_cli module. The issue results from the lack of proper validation of a user-supplied command before using it to execute a system call. An attacker can leverage this vulnerability to execute code in the context of root. Was ZDI-CAN-19838.
Affected products
- NETGEAR RAX30: before 1.0.10.94 — fixed in 1.0.10.94
How to fix
Upgrade to a fixed version: NETGEAR RAX30 1.0.10.94. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000065619/Security-Advisory-for-Multiple-Vulnerabilities-on-the-RAX30-PSV-2022-0348
- https://www.zerodayinitiative.com/advisories/ZDI-23-498/
- https://kb.netgear.com/000065619/Security-Advisory-for-Multiple-Vulnerabilities-on-the-RAX30-PSV-2022-0348
- https://www.zerodayinitiative.com/advisories/ZDI-23-498/
Get alerted when CVE-2023-27367 or the next vulnerability affects your stack