What’s Vulnerable › Vulnerabilities
CVE-2023-2743: WP ERP < 1.12.4 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-27 · updated 2026-06-17
Description
The ERP WordPress plugin before 1.12.4 does not sanitise and escape the employee_name parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.
Affected products
- weDevs WP ERP: before 1.12.4 — fixed in 1.12.4
How to fix
Upgrade to a fixed version: weDevs WP ERP 1.12.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/517c6aa4-a56d-4f13-b370-7c864dd9c7db
- https://wpscan.com/vulnerability/517c6aa4-a56d-4f13-b370-7c864dd9c7db
Get alerted when CVE-2023-2743 or the next vulnerability affects your stack