What’s Vulnerable › Vulnerabilities
CVE-2023-2744: WP ERP < 1.12.4 - Admin+ SQL Injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-27 · updated 2026-06-17
Description
The ERP WordPress plugin before 1.12.4 does not properly sanitise and escape the `type` parameter in the `erp/v1/accounting/v1/people` REST API endpoint before using it in a SQL statement, leading to a SQL injection exploitable by high privilege users such as admin.
Affected products
- weDevs WP ERP: before 1.12.4 — fixed in 1.12.4
How to fix
Upgrade to a fixed version: weDevs WP ERP 1.12.4. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/175106/WordPress-WP-ERP-1.12.2-SQL-Injection.html
- https://wpscan.com/vulnerability/435da8a1-9955-46d7-a508-b5738259e731
- http://packetstormsecurity.com/files/175106/WordPress-WP-ERP-1.12.2-SQL-Injection.html
- https://wpscan.com/vulnerability/435da8a1-9955-46d7-a508-b5738259e731
Get alerted when CVE-2023-2744 or the next vulnerability affects your stack