What’s Vulnerable › Vulnerabilities

CVE-2023-2745: WordPress Core < 6.2.1 - Directory Traversal

Description

WordPress Core is vulnerable to Directory Traversal in versions up to, and including, 6.2, via the ‘wp_lang’ parameter. This allows unauthenticated attackers to access and load arbitrary translation files. In cases where an attacker is able to upload a crafted translation file onto the site, such as via an upload form, this could be also used to perform a Cross-Site Scripting attack.

Affected products

How to fix

Upgrade to a fixed version: WordPress 4.1.38, 4.2.35, 4.3.31, 4.4.30. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-2745 or the next vulnerability affects your stack