What’s Vulnerable › Vulnerabilities
CVE-2023-27476: XML External Entity (XXE) Injection in OWSLib
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-08 · updated 2026-06-17
- Weakness: CWE-611
Description
OWSLib is a Python package for client programming with Open Geospatial Consortium (OGC) web service interface standards, and their related content models. OWSLib's XML parser (which supports both `lxml` and `xml.etree`) does not disable entity resolution, and could lead to arbitrary file reads from an attacker-controlled XML payload. This affects all XML parsing in the codebase. This issue has been addressed in version 0.28.1. All users are advised to upgrade. The only known workaround is to patch the library manually. See `GHSA-8h9c-r582-mggc` for details.
Affected products
- geopython OWSLib: before 0.28.1 — fixed in 0.28.1
How to fix
Upgrade to a fixed version: geopython OWSLib 0.28.1. Check the vendor advisory for mitigations.
References
- https://github.com/geopython/OWSLib/pull/863/commits/b92687702be9576c0681bb11cad21eb631b9122f
- https://github.com/geopython/OWSLib/security/advisories/GHSA-8h9c-r582-mggc
- https://lists.debian.org/debian-lts-announce/2023/06/msg00032.html
- https://securitylab.github.com/advisories/GHSL-2022-131_owslib/
- https://www.debian.org/security/2023/dsa-5426
- https://github.com/geopython/OWSLib/pull/863/commits/b92687702be9576c0681bb11cad21eb631b9122f
- https://github.com/geopython/OWSLib/security/advisories/GHSA-8h9c-r582-mggc
- https://lists.debian.org/debian-lts-announce/2023/06/msg00032.html
- https://securitylab.github.com/advisories/GHSL-2022-131_owslib/
- https://www.debian.org/security/2023/dsa-5426
Get alerted when CVE-2023-27476 or the next vulnerability affects your stack