What’s Vulnerable › Vulnerabilities
CVE-2023-27486: Insufficient authorization validation between zones when xCAT zones are enabled
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-08 · updated 2026-06-17
- Weakness: CWE-863
Description
xCAT is a toolkit for deployment and administration of computer clusters. In versions prior to 2.16.5 if zones are configured as a mechanism to secure clusters in XCAT, it is possible for a local root user from one node to obtain credentials to SSH to any node in any zone, except the management node of the default zone. XCAT zones are not enabled by default. Only users that use the optional zone feature are impacted. All versions of xCAT prior to xCAT 2.16.5 are vulnerable. This problem has been fixed in xCAT 2.16.5. Users making use of zones should upgrade to 2.16.5. Users unable to upgrade may mitigate the issue by disabling zones or patching the management node with the fix contained in commit `85149c37f49`.
Affected products
- xcat2 xcat-core: before 2.16.5 — fixed in 2.16.5
How to fix
Upgrade to a fixed version: xcat2 xcat-core 2.16.5. Check the vendor advisory for mitigations.
References
- https://github.com/xcat2/xcat-core/issues/7246
- https://github.com/xcat2/xcat-core/pull/7247
- https://github.com/xcat2/xcat-core/pull/7247/commits/85149c37f49dbca7bd85f1f586960315604fc024
- https://github.com/xcat2/xcat-core/security/advisories/GHSA-hpxg-7428-6jvv
- https://github.com/xcat2/xcat-core/issues/7246
- https://github.com/xcat2/xcat-core/pull/7247
- https://github.com/xcat2/xcat-core/pull/7247/commits/85149c37f49dbca7bd85f1f586960315604fc024
- https://github.com/xcat2/xcat-core/security/advisories/GHSA-hpxg-7428-6jvv
Get alerted when CVE-2023-27486 or the next vulnerability affects your stack