What’s Vulnerable › Vulnerabilities
CVE-2023-27491: Envoy forwards invalid Http2/Http3 downstream headers
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-04 · updated 2026-06-17
- Weakness: CWE-20
Description
Envoy is an open source edge and service proxy designed for cloud-native applications. Compliant HTTP/1 service should reject malformed request lines. Prior to versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9, There is a possibility that non compliant HTTP/1 service may allow malformed requests, potentially leading to a bypass of security policies. This issue is fixed in versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9.
Affected products
- envoyproxy envoy: before 1.22.9; from 1.23.0 before 1.23.6; from 1.24.0 before 1.24.4; from 1.25.0 before 1.25.3 — fixed in 1.22.9, 1.23.6, 1.24.4, 1.25.3
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.22.9, 1.23.6, 1.24.4, 1.25.3. Check the vendor advisory for mitigations.
References
- https://datatracker.ietf.org/doc/html/rfc9113#section-8.3
- https://datatracker.ietf.org/doc/html/rfc9114#section-4.3.1
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-5jmv-cw9p-f9rp
- https://www.rfc-editor.org/rfc/rfc9110#section-5.6.2
- https://datatracker.ietf.org/doc/html/rfc9113#section-8.3
- https://datatracker.ietf.org/doc/html/rfc9114#section-4.3.1
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-5jmv-cw9p-f9rp
- https://www.rfc-editor.org/rfc/rfc9110#section-5.6.2
Get alerted when CVE-2023-27491 or the next vulnerability affects your stack